Commit a6768b07 authored by Chris Croome's avatar Chris Croome

README Troubleshooting section updated

parent 18e35e78
......@@ -133,10 +133,58 @@ Then try restarting Docker:
```bash
service docker restart
```
```
See [this thread](https://help.nextcloud.com/t/failure-please-ensure-the-file-type-is-supported-and-not-corrupted/8031).
Tests you can try to see what is happening with Collabora:
```bash
curl --insecure -m 2 https://127.0.0.1:9980/
```
This should return `OK`.
Check that static files are being served from the container:
```bash
curl --insecure -m 2 https://127.0.0.1:9980/loleaflet/dist/loleaflet.html
```
Enter the Docker container:
```bash
docker exec -t -i $(docker ps -q) /bin/bash
```
List of released containers can be found on [hub.docker.com](https://hub.docker.com/r/collabora/code/tags/), to pull and run a specific one:
```bash
docker image pull collabora/code:3.4.0.8
docker run -t -d -p 127.0.0.1:9980:9980 -e "domain=${ESCAPED_HOSTNAME}" -e "dictionaries=en_GB en_US es_ES fr_FR de_DE" --restart always --cap-add MKNOD collabora/code:3.4.0.8
```
To get a list of available docker-ce versions:
```bash
apt-cache madison docker-ce
```
Stop Docker and downgrade and restart:
```bash
service docker stop
apt-get install docker-ce=18.06.0~ce~3-0~debian
apt-mark hold docker-ce
service docker restart
```
Then when you are able to upgrade un-hold the package:
```bash
apt-mark unhold docker-ce
```
### Prosody / xmpp-cloud-auth
Tests you can try:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment